Product Update SV 1.25.4
Maintenance
2025-04-25T08:36:00.0000000Z
Product Update SV 1.25.4
Status: closed
Start:
2025-04-25T07:00:00.0000000Z
End:
2025-04-25T08:36:00.0000000Z
Duration: 1 hour 36 minutes
Affected Components:
AMN Interpreting
Video Remote Interpreting (VRI)
Over Phone Interpreting (OPI)
Update
2025-04-25T07:00:00.0000000Z
2025-04-25T07:00:00.0000000Z
System Admin will deploy SV 1.25.4, no downtime is expected.
Resolved
2025-04-25T08:36:00.0000000Z
2025-04-25T08:36:00.0000000Z
System Admin has deployed SV 1.25.4.