Customer Support Phone Line Interruption

Incident

Customer Support Phone Line Interruption

Status: closed
Start:
End:
Duration: 35 minutes
Affected Components:
Customer Support Team
Update

Description: We are currently experiencing issues with our customer support phone line, 855-663-1231. When dialed, the line continues to ring without connecting to an agent. If you have an urgent issue, please email us at lscs@amnhealthcare.com. This is not affecting any of our interpreting services. 

What action do I need to take? Please email us at lscs@amnhealthcare.com for any urgent requests until this issue has been resolved. We will send out an update email when the phone line is once again available. 

How can I get more information? If you have further questions, please reach out to our Customer Success Team by emailing lscs@amnhealthcare.com

Resolved

Our customer support phone line is now fully operational, and calls are successfully connecting to our agents.