P4 - Interpreter Scheduler 25.9.1

Maintenance

P4 - Interpreter Scheduler 25.9.1

Status: closed
Start:
End:
Duration: 31 minutes
Affected Components:
AMN Interpreter Scheduler Interpreter Scheduler Consumer Web Application (CWA) Interpreter Mobile app - Resource Mobile App (RMA)
Update

What’s New: Sysadmin will deploy Interpreter Scheduler version 25.9.1.

You can view the release notes in the AMN LS Customer knowledge base. If you do not have access to the knowledge base, please request access by email at lscs@amnhealthcare.com.

Release Dates:

  • Consumer Web App: September 24, 2025 (2:00 PM ET)
  • Resource Mobile App: September 24, 2025 (2:00 PM ET)

Downtime Expected: No downtime is expected.

What action do I need to take

If you are using the Consumer Web App during the update window, you may need to logout and refresh the website.

Your interpreters may need to update to the latest version manually. Please ask them to use the appropriate app store link below based on their device:

How can I get more information? If you have further questions, please reach out to our Customer Success Team by emailing lscs@amnhealthcare.com or call 855.663.1231

Update

Update: The expected downtime has been revised.

Downtime Expected: No downtime is expected.

Resolved

What’s New: Sysadmin has deployed Interpreter Scheduler version 25.9.1.

You can view the release notes in the AMN LS Customer knowledge base. If you do not have access to the knowledge base, please request access by email at lscs@amnhealthcare.com.

What action do I need to take? Your interpreters may need to update to the latest version manually. Please ask them to use the appropriate app store link below based on their device:

How can I get more information? If you have further questions, please reach out to our Customer Success Team by emailing lscs@amnhealthcare.com or call 855.663.1231