P4 - Interpreter Scheduler 25.10.5

Maintenance

P4 - Interpreter Scheduler 25.10.5

Status: closed
Start:
End:
Duration: 52 minutes
Affected Components:
AMN Interpreter Scheduler Interpreter Scheduler Consumer Web Application (CWA)
Update

What’s New: Sysadmin will deploy Interpreter Scheduler version 25.10.5.

Release Dates:

  • Consumer Web App: January 8, 2026 (9:30 PM ET)

Downtime Expected:  No downtime is expected.

What action do I need to take

If you are using the Consumer Web App during the update window, you may need to logout and refresh the website.

How can I get more information? If you have further questions, please reach out to our Customer Success Team by emailing lscs@amnhealthcare.com or call 855.663.1231

Resolved

Update: Interpreter Scheduler version 25.10.5 has been deployed successfully.

Description: Sysadmin will deploy Interpreter Scheduler version 25.10.5

How can I get more information? If you have further questions, please reach out to our Customer Success Team by emailing lscs@amnhealthcare.com or call 855.663.1231